wiki:MovingPieces

Version 6 (modified by dulcaoin@…, 10 years ago) (diff)

--

Moving pieces

Pieces (or groups of pieces) that have been selected can be moved using the Move tool (toolbar icon )

Tip: LeoCAD automatically switches to the Move function after adding a new piece if this option has been enabled via the Preferences menu (Select the View menu, click "Preferences", select the "Drawing Aids" tab and check "Switch to move after inserting").

Movement of pieces can be performed using the keyboard. The arrow keys move along 2 of the axes, while PageUp and PageDown move along the third.

Tip: The movement keys (Up-Arrow, Down-Arrow, Left-Arrow, Right-Arrow, PageUp, and PageDown) act in one of two ways, dependent upon whether the "Fixed direction keys" option is checked or not. To change this setting, Select the View menu, click "Preferences", select the "Drawing Aids" tab and either check or clear "Fixed direction keys".

When "Fixed direction keys" is clear, the movement keys act relative to the active viewport. For instance, if the active view is Front, the Up-Arrow and Down-Arrow keys will move the piece along the Z-axis (up and down), while the Left-Arrow and Right-Arrow keys move the piece along the Y-axis (sideways). When you switch to the Top view, then the arrows act differently: Up-Arrow and Down-Arrow move the piece along the X-axis (forward and back, but "up and down" relative to that view), and Left-Arrow and Right-Arrow continue to move the piece along the Y-axis (sideways). [Note: As of this writing, when the Main view is active, the arrow keys move the piece "backwards" from what is intuitive: forward-backward are switched, as are left-right; up-down act as expected.]

When "Fixed direction keys" is checked, the movement keys always move the piece in the same way, no matter which viewport is active: the arrow keys move pieces along the X-axis and Y-axis, and the PageUp and PageDown keys move pieces along the Z-axis.

A more interactive method uses mouse Click-and-Drag operations as illustrated below.

In Move mode, a three-colored overlay appears on the selected piece, representing the X, Y, and Z axes.

Move the mouse cursor towards an arrow until it turns yellow, then Click-and-Drag the mouse along the arrow to move the piece along the corresponding axis. The element will appear to "ratchet" along that axis, subject to the current grid snap settings (see Snap Grid, below).
The red arrow represents the X-axis, while green represents the Y-axis and blue represents the Z-Axis.

If the mouse cursor is moved towards the origin of the arrows (where they meet), a yellow square appears between two arrows, which will both turn yellow. Click-and-Drag the mouse to move the piece in the plane defined by these axis. The element will "ratchet" its position in two axes at once (see Snap Grid below).
The position of the piece will be displayed, live, via the coordinates display on the right-hand side of the status bar along the bottom of the LeoCAD window.
Snap GridPiece movements occur in discrete chunks, controlled by the snap grid. You can change the size of these steps or disable partially or totally the snap action: see snap grid control.
You can also move a piece using the "Piece Modify" dialog box.
To get to this dialog box, check "Modify" in the "View" menu. Select a piece, enter its new X/Y/Z coordinates and click on the "Apply" button.

Tip: You don't have to switch to the "select" tool to select and move another piece. Simply double-click on it using the "move" cursor to make it the new selected element. Hold down the Ctrl key while double clicking on elements in Move mode to select multiple elements at once.

Tip: Perspective effects can make a piece appear close to another while they are actually far apart. Change camera or move it? to get a better view.

Attachments (15)

Download all attachments as: .zip